#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\b[a-zA-Z']+\b"
Local $sString = "JÖNAS" & @CRLF & _
"Hélton" & @CRLF & _
"As kingfishers catch fire, dragonflies draw flame;" & @CRLF & _
"As tumbled over rim in roundy wells" & @CRLF & _
"Stones ring; like each tucked string tells, each hung bell's" & @CRLF & _
"Bow swung finds tongue to fling out broad its name;" & @CRLF & _
"Each mortal thing does one thing..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")