const regex = /.*\/\s*(\d+)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\/\\s*(\\d+)\\s*$', 'gm')
const str = `1 / 132 / 133 / 134 / 135 / 136 / 137 / 138 / 139 / 1310 / 1311 / 1312 / 1313 / 13
1 / 82 / 83 / 84 / 85 / 86 / 87 / 88 / 8
1 / 152 / 153 / 154 / 155 / 156 / 157 / 158 / 159 / 1510 / 1511 / 1512 / 1513 / 1514 / 1515/ 15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}