$re = '/(http:\/\/|https:\/\/)((([0-9]\.){4})|[a-z0-9\-_\.][a-z0-9\-_\.]+)(\:)([0-9]{1,5})/';
$str = 'http://node.org:443
https://sa.com:1
https://a:31
123.123.123.123:231
http://213.123.123.122:231';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);