using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!Vol)(?!Chapter)(?<Series>.+?)(-|_|\s|#)\d+(-\d+\b)?(.+?(?=\s+->))?";
string input = @"Test cases:
Kodoja #001 (March 2016) -> Kodoja
Bleach 001-002 -> Bleach
[BAA]_Darker_than_Black_Omake-1 -> [BAA]_Darker_than_Black_Omake
Edge cases:
The Archmage Returns After 4000 Years -> The Archmage Returns After
See You in My 19th Life -> See You in My
The Return of the 8th Class Mage -> The Return of the
Kaiju No. 8 -> Kaiju No.
Zom 100 - Bucket List of the Dead -> Zom";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}