import Foundation
let pattern = ##"^(?!Vol)(?!Chapter)(?<Series>.+?)(-|_|\s|#)\d+(-\d+\b)?(.+?(?=\s+->))?"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Test cases:
Kodoja #001 (March 2016) -> Kodoja
Bleach 001-002 -> Bleach
[BAA]_Darker_than_Black_Omake-1 -> [BAA]_Darker_than_Black_Omake
Edge cases:
The Archmage Returns After 4000 Years -> The Archmage Returns After
See You in My 19th Life -> See You in My
The Return of the 8th Class Mage -> The Return of the
Kaiju No. 8 -> Kaiju No.
Zom 100 - Bucket List of the Dead -> Zom
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)