use strict;
my $str = 'valid-id@example.com';
my $regex = qr/^(
\s*
| .* \s .*
| (?:undefined|null|nan|infinity|true|false)
| (?:test(?:ing)?|example|guest|anonymous|anon|user|visitor|n/?a)
| \[object \s [^\]]+ \]
| [-._+/=:@~]+
| [A-Za-z0-9._\-+/=:@~]{,2}
| [A-Za-z0-9._\-+/=:@~]{256,}
)$/mxip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}