import Foundation
let pattern = #"""
^(
\s*
| .* \s .*
| (?:undefined|null|nan|infinity|true|false)
| (?:test(?:ing)?|example|guest|anonymous|anon|user|visitor|n/?a)
| \[object \s [^\]]+ \]
| [-._+/=:@~]+
| [A-Za-z0-9._\-+/=:@~]{,2}
| [A-Za-z0-9._\-+/=:@~]{256,}
)$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"valid-id@example.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)