re = /(?:\bSTART\b|\G(?<!\A))(?!.*\bEND\b).*+\K\R/m
str = 'some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify'
subst = '\\n\\t'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result