$re = '/[[:punct:]]|\w+/m';
$str = '12 + (ab-bc*3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);