#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^(?=({\w+(?1)?})$)|\G(?!\A)){(\w+)"
Local $sString = "{pppppp" & @CRLF & _
"{a}" & @CRLF & _
"{a{b}}" & @CRLF & _
"{a{b{c}}}" & @CRLF & _
"{a{b{c{d}}}}" & @CRLF & _
"{a{bb{ccc{dd}}}}" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"{{a}" & @CRLF & _
"{a}}" & @CRLF & _
"{a}b" & @CRLF & _
"z{a{b}}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")