import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?=(\\{\\w+(?1)?\\})$)|\\G(?!\\A))\\{(\\w+)";
final String string = "{pppppp\n"
+ "{a}\n"
+ "{a{b}}\n"
+ "{a{b{c}}}\n"
+ "{a{b{c{d}}}}\n"
+ "{a{bb{ccc{dd}}}}\n\n"
+ "a\n"
+ "{{a}\n"
+ "{a}}\n"
+ "{a}b\n"
+ "z{a{b}}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}