re = /(?:^(?=({\w+(?1)?})$)|\G(?!\A)){(\w+)/m
str = '{pppppp
{a}
{a{b}}
{a{b{c}}}
{a{b{c{d}}}}
{a{bb{ccc{dd}}}}
a
{{a}
{a}}
{a}b
z{a{b}}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end