re = /(?<![.a-zA-Z_0-9])\d+(?![a-zA-Z_0-9])/m
str = 'a bcd 43.43 432 и л фвыа 89 .98
fdfdfd.98dsfs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end