import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?[A-Z])[^0-9].{7,}$";
final String string = "fdhf\n"
+ "fdifhidhfdfd\n"
+ "hfhfhfhf\n"
+ "3343rAjrj\n"
+ "bd1A23nfdd\n"
+ "bd123nfDdd\n\n"
+ "abd16A3n\n"
+ "bad176A23n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}