# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?::|^)((?:0+:){2,}0+)(?=:|$)|(?::|^)(0+)([0-9a-f]+)(?=:|$)|\b0+([0-9a-f]{1,4})\b/${1:+::}${3}${4}/gi;t' <<< "2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
a:b:0:c:d:e:f:g
2001:0db8:abcd:0012:0000:0000:0000:0001
:00ff:0000:
0012:0000:0000:0000:0001"