using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?::|^)((?:0+:){2,}0+)(?=:|$)|(?::|^)(0+)([0-9a-f]+)(?=:|$)|\b0+([0-9a-f]{1,4})\b";
string substitution = @"${1:+::}${3}${4}";
string input = @"2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
a:b:0:c:d:e:f:g
2001:0db8:abcd:0012:0000:0000:0000:0001
:00ff:0000:
0012:0000:0000:0000:0001";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}