import Foundation
let pattern = #"(?::|^)((?:0+:){2,}0+)(?=:|$)|(?::|^)(0+)([0-9a-f]+)(?=:|$)|\b0+([0-9a-f]{1,4})\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
a:b:0:c:d:e:f:g
2001:0db8:abcd:0012:0000:0000:0000:0001
:00ff:0000:
0012:0000:0000:0000:0001
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1:+::}${3}${4}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)