# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:(?:0{2,}(:))+0*|0+\B)/$1/gmi;t' <<< "2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
a:b:0:c:d:e:f:g
2001:0db8:abcd:0012:0000:0000:0000:0001
:00ff:0000:
0012:0000:0000:0000:0001
0000:0000:0000:0000:0001
0000:0000:1234:0000:0000
0001:0000:0000:0000:0000"