#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\b(?:(?:0{2,}(:))+0*|0+\B)"
Local $sString = "2001:0db8:abcd:0012:0000:0000:0000:0001" & @CRLF & _
"2001:0db8:abcd:0012:0000:0000:0000:00a2" & @CRLF & _
"2001:0db8:abcd:0012:0000:0000:0000:00ff" & @CRLF & _
"a:b:0:c:d:e:f:g" & @CRLF & _
"2001:0db8:abcd:0012:0000:0000:0000:0001" & @CRLF & _
":00ff:0000:" & @CRLF & _
"0012:0000:0000:0000:0001" & @CRLF & _
"0000:0000:0000:0000:0001" & @CRLF & _
"0000:0000:1234:0000:0000" & @CRLF & _
"0001:0000:0000:0000:0000"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)