package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\w'\-,.][^0-9_!¡?÷?¿\/\\+=@#$%ˆ&*(){}|~<>;:[\]]{2,}$`)
var str = `<InvalidName1>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}