// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<Button(?:\w+=\{[^{}]*\}|[^>])*\sclassName=(?:\w+=\{[^{}]*\}|[^>])*>").unwrap();
let string = "<Button className={style.red} />
<Button className={style.red}> </Button>
<Button
palette=\"primary\"
className={style.blue}
/>
<Button
palette=\"primary\"
/>
<Button
palette=\"primary\"
className={style.blue}
>
</Button>
<Button
palette=\"primary\"
condition={ value => 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette=\"primary\"
condition={ value <= 5 ? props1 : props2 }
className={style.blue}
/>
<Button
palette=\"primary\"
className={style.blue}
condition={ value => 5 ? props1 : props2 }
/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}