re = /#EPCDatabase\/EPCdatabase.param\/epc.db.user=.*$/im
str = '# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.user=
# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.password=
# Mandatory parameter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end