#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w[\w\.]*)(?=@\w+\.[\w\.]+)\b"
Local $sString = "" & @CRLF & _
"I need a regular expression that will match email addresses, but exclude specific email addresses from the match" & @CRLF & _
"" & @CRLF & _
"e.g. do not match;" & @CRLF & _
"charlie@outrunthebear.co.uk" & @CRLF & _
"mailto: sponge.bob@example.com" & @CRLF & _
"jim.bob@example.com" & @CRLF & _
"billy.bob@example.com" & @CRLF & _
"match all other email addresses;" & @CRLF & _
"" & @CRLF & _
"may be test@example.com or a@b.com a.b.c@d.e.f.com" & @CRLF & _
"no.body@example.com" & @CRLF & _
"another.test.email@example.com" & @CRLF & _
"and.another.one@example.com.au"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")