# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\(\d+\)//gm;t' <<< "code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z"