#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\(\d+\)"
Local $sString = "code (2021)" & @CRLF & _
"names (2021)" & @CRLF & _
"all the info you need (AIYN) from A to Z" & @CRLF & _
"some info you need (SIYN) from A to Z"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)