using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\(\d+\)";
string substitution = @"";
string input = @"code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}