re = /\s*\(\d+\)/m
str = 'code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result