import Foundation
let pattern = #"\s*\(\d+\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)