re = /(.+?)(?:\.\[(\d{4}\-\d{4}\s?|\d{4}\-\s?|\d{4}\s?)?([^\]]*)\])?(?:\.(.+))?
/m
str = 'Azertyuiop £££.[2024].Mini-série
Azertyuiop - qsdfghjklm.[2021-2023 Netflix].Manga
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end