$re = '/[^:]+$/m';
$str = 'WN (Hoàn thành) - 11: Đệ tử và Goblin (End)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);