using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/uslugi/([a-zA-Z0-9\\.\\-_]+)/([^/]*)";
string input = @"/uslugi/test/?hello
/uslugi/some.link
/uslugi/some.link/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}