re = /^\/uslugi\/([a-zA-Z0-9\\.\\-_]+)\/([^\/]*)/m
str = '/uslugi/test/?hello
/uslugi/some.link
/uslugi/some.link/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end