#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "BN((6(0[0-9]|1[0134]|2[1-9]|3[0-1]))|7(0[68]|1(0|1[A-C])|2([1-4]|5|[7-9])|3[01]))"
Local $sString = "BN601" & @CRLF & _
"BN602" & @CRLF & _
"BN603" & @CRLF & _
"BN604" & @CRLF & _
"BN605" & @CRLF & _
"BN606" & @CRLF & _
"BN607" & @CRLF & _
"BN608" & @CRLF & _
"BN609" & @CRLF & _
"BN610" & @CRLF & _
"BN611" & @CRLF & _
"BN612" & @CRLF & _
"BN613" & @CRLF & _
"BN614" & @CRLF & _
"BN615" & @CRLF & _
"BN616" & @CRLF & _
"BN617" & @CRLF & _
"BN618" & @CRLF & _
"BN619" & @CRLF & _
"BN620" & @CRLF & _
"BN621" & @CRLF & _
"BN622" & @CRLF & _
"BN623" & @CRLF & _
"BN624" & @CRLF & _
"BN625" & @CRLF & _
"BN626" & @CRLF & _
"BN627" & @CRLF & _
"BN628" & @CRLF & _
"BN629" & @CRLF & _
"BN630" & @CRLF & _
"BN631" & @CRLF & _
"BN632" & @CRLF & _
"BN701" & @CRLF & _
"BN702" & @CRLF & _
"BN703" & @CRLF & _
"BN704" & @CRLF & _
"BN705" & @CRLF & _
"BN706" & @CRLF & _
"BN707" & @CRLF & _
"BN708" & @CRLF & _
"BN709" & @CRLF & _
"BN710" & @CRLF & _
"BN711" & @CRLF & _
"BN711A" & @CRLF & _
"BN711B" & @CRLF & _
"BN711C" & @CRLF & _
"BN711a" & @CRLF & _
"BN711b" & @CRLF & _
"BN711c" & @CRLF & _
"BN712" & @CRLF & _
"BN713" & @CRLF & _
"BN714" & @CRLF & _
"BN715" & @CRLF & _
"BN716" & @CRLF & _
"BN717" & @CRLF & _
"BN718" & @CRLF & _
"BN719" & @CRLF & _
"BN720" & @CRLF & _
"BN721" & @CRLF & _
"BN722" & @CRLF & _
"BN723" & @CRLF & _
"BN724" & @CRLF & _
"BN725" & @CRLF & _
"BN726" & @CRLF & _
"BN727" & @CRLF & _
"BN728" & @CRLF & _
"BN729" & @CRLF & _
"BN730" & @CRLF & _
"BN731" & @CRLF & _
"BN732" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")