$re = '/https?:\/\/.+?(foo\.com)[^\/]+(?<data>(\/[^\/]+){2}\/)/';
$str = 'http://www.foo.com:80/main.html
http://www.foo.com:80/xe/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee1232131/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee/journal/v1/book/nF1.jpg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);