# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[<a(\s+[a-zA-Z\-][a-zA-Z0-9\-]*(=(\"[^\"]*\"|'[^']*'|[a-zA-Z0-9\-_]+)?)?)*\s*>([^<]*|<[^a]|<a[^ >])+<\/a\s*>\]"
test_str = ("<div> \n"
" <br/>\n"
" <div style=\"text-align: left;\"> \n"
" <p style=\"margin-top: 0px; margin-bottom: 0px;\"> [<a id=\"Offer no. SGE - 100818 - 2 - Klb (24XLR - steel washing).doc\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/Offer%20no.%20SGE%20-%20%20100818%20-%20%202%20-%20Klb%20(24XLR%20-%20steel%20washing).doc\">Offer no. SGE -  100818 -  2 - Klb (24XLR - steel washing).doc</a>] [<a id=\"_PO4501258976_EUR.pdf\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/_PO4501258976_EUR.pdf\">_PO4501258976_EUR.pdf</a>] </p> \n"
" </div>\n"
" <br/>\n"
" <div style=\"text-align: left; color: #000000; font-family: arial, san-serif; font-size: 9pt;\"> \n"
" <p style=\"margin-top: 0px; margin-bottom: 0px;\">Rechnungen im Einzelnen (lt. Linda Gölzenleuchter/Praktikantin RTB) Stand 05.05.2011</p> \n"
" </div>\n"
" <br/>\n"
" <div style=\"text-align: left;\"> \n"
" <p style=\"margin-top: 0px; margin-bottom: 0px;\"> [<a id=\"2011_05.pdf\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_05.pdf\">2011_05.pdf</a>] [<a id=\"2011_01.pdf\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_01.pdf\">2011_01.pdf</a>] </p> \n"
" </div> \n"
"</div>\n"
"<br/>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.