// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[<a(\s+[a-zA-Z\-][a-zA-Z0-9\-]*(=("[^"]*"|'[^']*'|[a-zA-Z0-9\-_]+)?)?)*\s*>([^<]*|<[^a]|<a[^ >])+<\/a\s*>\]"#).unwrap();
let string = "<div>
<br/>
<div style=\"text-align: left;\">
<p style=\"margin-top: 0px; margin-bottom: 0px;\"> [<a id=\"Offer no. SGE - 100818 - 2 - Klb (24XLR - steel washing).doc\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/Offer%20no.%20SGE%20-%20%20100818%20-%20%202%20-%20Klb%20(24XLR%20-%20steel%20washing).doc\">Offer no. SGE -  100818 -  2 - Klb (24XLR - steel washing).doc</a>] [<a id=\"_PO4501258976_EUR.pdf\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/_PO4501258976_EUR.pdf\">_PO4501258976_EUR.pdf</a>] </p>
</div>
<br/>
<div style=\"text-align: left; color: #000000; font-family: arial, san-serif; font-size: 9pt;\">
<p style=\"margin-top: 0px; margin-bottom: 0px;\">Rechnungen im Einzelnen (lt. Linda Gölzenleuchter/Praktikantin RTB) Stand 05.05.2011</p>
</div>
<br/>
<div style=\"text-align: left;\">
<p style=\"margin-top: 0px; margin-bottom: 0px;\"> [<a id=\"2011_05.pdf\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_05.pdf\">2011_05.pdf</a>] [<a id=\"2011_01.pdf\" href=\"/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_01.pdf\">2011_01.pdf</a>] </p>
</div>
</div>
<br/>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}