use strict;
my $str = '<div>
<br/>
<div style="text-align: left;">
<p style="margin-top: 0px; margin-bottom: 0px;"> [<a id="Offer no. SGE - 100818 - 2 - Klb (24XLR - steel washing).doc" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/Offer%20no.%20SGE%20-%20%20100818%20-%20%202%20-%20Klb%20(24XLR%20-%20steel%20washing).doc">Offer no. SGE -  100818 -  2 - Klb (24XLR - steel washing).doc</a>] [<a id="_PO4501258976_EUR.pdf" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/_PO4501258976_EUR.pdf">_PO4501258976_EUR.pdf</a>] </p>
</div>
<br/>
<div style="text-align: left; color: #000000; font-family: arial, san-serif; font-size: 9pt;">
<p style="margin-top: 0px; margin-bottom: 0px;">Rechnungen im Einzelnen (lt. Linda Gölzenleuchter/Praktikantin RTB) Stand 05.05.2011</p>
</div>
<br/>
<div style="text-align: left;">
<p style="margin-top: 0px; margin-bottom: 0px;"> [<a id="2011_05.pdf" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_05.pdf">2011_05.pdf</a>] [<a id="2011_01.pdf" href="/apps/BIZ4TS/migration/Lists/Angebot3/Attachments/9/2011_01.pdf">2011_01.pdf</a>] </p>
</div>
</div>
<br/>
';
my $regex = qr/\[<a(\s+[a-zA-Z\-][a-zA-Z0-9\-]*(=("[^"]*"|'[^']*'|[a-zA-Z0-9\-_]+)?)?)*\s*>([^<]|<[^a]|<a[^ >])+<\/a>\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}