# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([-'])\b|(?!\n)[\W_]/\1/gm;t' <<< "That's
a-
tasty
tic-tac.
Or
-not?"