using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([-'])\b|(?!\n)[\W_]";
string substitution = @"\1";
string input = @"That's
a-
tasty
tic-tac.
Or
-not?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}