$re = '/\b([-\'])\b|(?!\n)[\W_]/m';
$str = 'That\'s
a-
tasty
tic-tac.
Or
-not?';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;