re = /\b([-'])\b|(?!\n)[\W_]/m
str = 'That\'s
a-
tasty
tic-tac.
Or
-not?'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result