import Foundation
let pattern = #"[-?|\D?]\d{2}\D?\d{2}\D?\d{4}\s??[-|–]?\s?\d{2}\D?\d{2}\D?\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Chiết khấu tháng: '0.04-01/01/2020-31/12/2020 .Chi trả kết thúc hàng tháng
Từ 01/01/2020-31/12/2020 TSL >=1500 tấn thưởng: 1% doanh thu, TSL >=1800 tấn thưởng: 1.5% doanh thu (chi trả kết thúc chương trình, dự chi mức 1.5% doanh thu)
Chiết khấu quý :01.01.2020-30.06.2020 :trừ 9048
1 HĐ CK01 1% 9048 từ 01/02/2020 - 31/05/2020
Chiết khấu TSL 3 tháng = 100 tấn 01/01/2020 31/03/2020;200 đ/kg Chi trả khi hoàn thành sản lượng, Sau điều chỉnh Từ 01/01/2020 -31/03/2020 chiết khấu TSL 3 tháng = 90.895kg: 200đ/kg (chi trả kết thúc chương trình)
Chiết khấu Năm 29/02/2020 đến 31/01/2021 1% Trong vòng 45 ngày kể từ thời điểm đủ 12 tháng kinh doanh liên tục.
Chiết khấu Tháng - Trừ SP 8888, 6688, 5588S, 8954, cá các loại 01/02/2020 – 31/01/2021 4% Ngày 10 tháng kế tiếp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)