import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=\\s)[A-z]+|(?<=\\.)[A-z\\s]+)(?=\\?)";
final String string = "Can you detect this?\n"
+ "Ok smarty pants, how about THIS?\n"
+ "Oh you're good...T H I S?\n"
+ "Dammit!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}