// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*facebook.com.groups.*|.*meetup.com.*)").unwrap();
let string = "facebook.com/groups/
facebook.com
facebook.com/groups/12245
facebook.com/groups
meetup.com ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}