# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\D+(\d+).*/\1/gm;t' <<< "filepath/23-00.xlsx"