#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)"([^"]+?)\s+\|\s+([^"]+?)""
Local $sString = ""Hello"|"Green | Blue"|123.45|""|""|""|5|45"
Local $sSubst = "\1 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)