const regex = /"([^"]+?)\s+\|\s+([^"]+?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]+?)\\s+\\|\\s+([^"]+?)"', 'gm')
const str = `"Hello"|"Green | Blue"|123.45|""|""|""|5|45`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);