using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https|git)(:\/\/|@)([^\/:]+)[\/:]([^\/:]+)(?:\/(.+).git)?$";
string input = @"git://github.com/some-user/my-repo.git
git@github.com:some-user/my-repo.git
https://github.com/some-user/my-repo.git
git://github.com/some-user
git@github.com:some-user
https://github.com/some-user
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}