$re = '/^(https|git)(:\/\/|@)([^\/:]+)[\/:]([^\/:]+)(?:\/(.+).git)?$/m';
$str = 'git://github.com/some-user/my-repo.git
git@github.com:some-user/my-repo.git
https://github.com/some-user/my-repo.git
git://github.com/some-user
git@github.com:some-user
https://github.com/some-user
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);