using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.*?)(\(\w{1,}\)))((\g<2>)(\g<3>))*";
string input = @"Geese (Flock) Dogs (Pack)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}